Service Update: Video Serving

Incident Report for Idomoo Statuspage

Resolved

The performance issues affecting video serving have been resolved. Systems are operating normally, and video delivery and playback performance have returned to standard levels. We appreciate your patience while we addressed this.
Posted Feb 01, 2026 - 05:48 EST

Investigating

We have identified a performance degradation affecting video serving services in the US region. Users may experience slower-than-usual video load or playback times. We are working to restore standard performance levels and appreciate your patience.
Posted Feb 01, 2026 - 05:18 EST